محتوا: Slate Blackcurrant Watermelon Strawberry Orange Banana Apple Emerald Chocolate Marble
پس زمینه: Slate Blackcurrant Watermelon Strawberry Orange Banana Apple Emerald Chocolate Marble
الگو: Blank Waves Notes Sharp Wood Rockface Leather Honey Vertical Triangles
به پشتیبانی اپن کارت فارسی خوش آمدید

بازدیدکننده گرامی به انجمن اپن کارت فارسی خوش آمدید،

برای دانلود اپن کارت فارسی و افزونه های منتشر شده به وب سایت ما مراجعه نمایید و برای استفاده از امکانات انجمن پشتیبانی اپن کارت فارسی ثبت نام نمایید.

opencartfarsi

آموزش بروزرسانی نسخه 1.5 به نسخه 2 اپن کارت

1 ارسال در این موضوع

راهنمای بروزرسانی نسخه 1.5 به نسخه 2 اپن کارت فارسی

قبل از بروزرسانی از نسخه 1.5 به نسخه 2، ابتدا به آخرین نسخه 1.5 اپن کارت یعنی 1.5.6.4 بروزرسانی نمایید، سپس طبق راهنمای زیر به نسخه 2 بروزرسانی نمایید :

نحوه بروزرسانی از نسخه 1.5.6.4 به نسخه 2.0.1.1 (اولین نسخه منتشر شده نسخه 2):

قبل از بروز رسانی حتما از دیتابیس و کل فایل های فروشگاهتان بکاپ بگیرید، چراکه در صورتی که هرگونه ویرایشی به صورتی دستی در هسته اپن کارت انجام شده باشد، حذف خواهد شد.

برای انجام بروز رسانی فایل های config.php و admin/config.php را از داخل اپن کارتی که دانلود کرده اید حذف کنید، 

در نسخه های قبلی (نسخه 1.5) در بروزرسانی پوشه image نیز از پکیج دانلود شده باید حذف می شد، اما بدلیل بروزرسانی این پوشه در این نسخه بهتر است حذف نشود.

توجه : با توجه به تغییرنام پوشه image/data به image/catalog در نسخه 2 تصاویر شما به درستی در فروشگاه نمایش داده می شوند اما مدیریت تصاویر دیگر به پوشه image/data دسترسی ندارد و فقط به پوشه image/catalog دسترسی دارد.

نکته در مورد ویکیومد و ocmod (تغییرات) :

بهتر است پوشه vqmod داخل هاستتان را تغییر نام دهید، تا از تداخل فایل ها جلوگیری شود، بعد از اتمام بروزرسانی می توانید فایل های xml قدیمی و غیرتکراری را بعد از اینکه با این نسخه سازگار کردید، به این نسخه منتقل کنید.

همچنین بعد از انجام بروزرسانی و ورود به مدیریت ابتدا ویکیومد را از طریق آدرس YourShop.ir/vqmod/install نصب کنید، سپس از مسیر "افزونه ها >> تغییرات" دکمه بروزرسانی را کلیک کنید تا کش تغییرات ساخته شود.

 

روش 1 برای بروزرسانی :

از آنجایی تغیرات نسخه 2 خیلی زیاد است و ماژول ها و قالب نسخه 1.5 روی نسخه 2 کار نمی کند بهتر است غیر از این دو فایل کانفیگ و پوشه تصویر بقیه فایل های اپن کارت را حذف کنید و نسخه جدید را اضافه و بروزرسانی کنید.

روش 2 برای بروزرسانی :

در این حالت فایل ها جایگزین می شوند ولی چون ماژول های نسخه 1.5 روی نسخه 2 کار نمی کنند، باید آنها را بعدا بروزرسانی کنید.

 

سپس باقی مانده فایل های فروشگاه سازی که دانلود کرده اید را فشرده، آپلود و در هاست اکسترکت نمایید.

و پوشه نصب (بروزرسانی) را به صورت http://YourShop.ir/install فراخوانی کنید.

پس از بروزرسانی و قبل از ورود به مدیریت فروشگاه نیاز است فایل های config.php و admin/config.php را به صورت زیر بروزرسانی کنید :

1. بروزرسانی مسیر پوشه دانلود از download به system/download در خط تعریف DIR_DOWNLOAD

2. تعریف مسیر پوشه آپلود و تغییرات به صورت زیر : (طبق نام کاربری و مسیر نصب که در فایلهای کانفیگ اپن کارت در هاست نوشته شده است این آدرسها را بروز رسانی کنید)

define('DIR_UPLOAD', '/home/YourUser/public_html/system/upload/');

define('DIR_MODIFICATION', '/home/YourUser/public_html/system/modification/');

define('DB_PORT', '3306');

3. چون در نسخه 2 کاربر api یا رابط برنامه نوسی نرم افزار اضافه شده است لازم است پس از اینکه به مدیریت وارد شدید به خطاهای قابل مشاهده توجهی نکنید و طبق معمول در مسیر "سیستم >> کاربران >> گروه های کاربری" به گروه مدیریت ارشد تمام دسترسی ها را بدهید، بعد به مسیر "سیستم >> کاربران >> رابط برنامه نویسی نرم افزار" بروید و یک کاربر api ایجاد نمایید و سپس به مسیر "سیستم >> تنظیمات" بروید و تنظیمات و فیلدهای جدید را مقداردهی کنید و کاربر api را هم انتخاب و سپس دکمه "ذخیره" را کلیک کنید، حال دیگر خطایی مشاهده نخواهید کرد.

نکته : در صورتی که در قسمت های مختلف مدیریت و فروشگاه که تاریخ شمسی دارند فیلد تاریخ مقداری نداشت کافیه پس از اینکه کش تغییرات ایجاد شد، مجددا به مسیر "سیستم >> تنظیمات" بروید و تنظیمات را ذخیره کنید تا متغیر فرمت تاریخ مقدارش ذخیره شود و در فرم های مختلف تاریخ دار امکان نمایش تاریخ وجود داشته باشد.

توجه : در صورتی که می خواهید به سایر نسخه های 2 اپن کار بروزرسانی کنید باید اول به 2.0.1.1 سپس به ترتیب به نسخه های بالاتر بروزرسانی نمایید. (آموزش)

توجه : با توجه به تغییرات بسیار زیادی که نسخه 2 نسبت به نسخه 1.5 داشته است، توجه داشته باشد بروزرسانی هسته اپن کارت باعث ناسازگاری فروشگاه شما یا ماژول ها و قالب فروشگاهتان می شود، پس نیاز است قبل از بروز رسانی با پشتیبانی فنی فروشگاهتان تماس بگیرید تا امکان بروزرسانی قالب، ماژول ها یا سایر امکانات اضافی فروشگاهتان به نسخه جدید را برایتان فراهم نماید.

 

2

به اشتراک گذاشتن این پست


لینک به پست
اشتراک در سایت های دیگر